Motion - Feature Request 2016x 03x 24x 105354

Feature Request: ip camera rt-n16 + motion = grey screen

Description

Hi guys,

I have problems with motion and I need the help. As the IP camera I have ASUS rt-n16 router. I have established open source firmware from Vampik(Oleg) and have connected the webcam to router usb. Now I can come to the address http://iserj.ru:7776 and to see the image of the apartment. Further I have installed motion on the server and have adjusted following in the way:

v4l2_palette 2 width 1024 height 768 framerate 25 netcam_url value http://iserj.ru:7776 netcam_userpass value XXX:XXX threshold 1500 noise_level 0 output_normal on quality 100 snapshot_interval 1

Further I start motion but as a result I have gray shots. I tried to turn off authorization on a camera/router but it hasn't helped. Lexis

iserj@iserj-Latitude-E4200:/etc/motion$ sudo motion -n -d7 [sudo] password for iserj: [0] Processing thread 0 - config file /etc/motion/motion.conf [0] Motion 3.2.12 Started [0] ffmpeg LIBAVCODEC_BUILD 3547904 LIBAVFORMAT_BUILD 3544067 [0] Thread 1 is from /etc/motion/motion.conf [1] Thread 1 started [1] entered netcam_start() [1] Camera thread starting... [1] netcam_start: Netcam_http parameter '1.0' converts to flags: HTTP1.0:1 HTTP1.1: 0 Keep-Alive OFF. [1] netcam_start: now calling netcam_setup_html() [1] netcam_setup_html: Netcam has flags: HTTP1.0: 1 HTTP1.1: 0 Keep-Alive OFF. [1] Camera connect string is ''GET HTTP/1.0 Host: iserj.ru User-Agent: Motion-netcam/3.2.12 Connection: close

'' [1] End of camera connect string. [1] netcam_setup_html: about to try to connect, time #0 [1] netcam_connect, disconnecting netcam since keep-alive not set. [1] netcam_connect with no keepalive, new socket created fd 3 [1] Received first header ('HTTP/1.0 400 Bad Request') [1] HTTP Result code 400 [1] netcam_setup_html: connected, going on to read image. [1] expanding buffer from 0 to 4096 bytes [1] netcam_read_html_jpeg disconnecting netcam since keep-alive not set. [1] libjpeg decompression failure on first frame - giving up! [1] Could not fetch initial image from camera [1] Motion continues using width and height from config file(s) [1] Resizing pre_capture buffer to 1 items [1] Retrying until successful connection with camera [1] entered netcam_start() [1] Camera thread starting... [1] netcam_start: Netcam_http parameter '1.0' converts to flags: HTTP1.0:1 HTTP1.1: 0 Keep-Alive OFF. [1] netcam_start: now calling netcam_setup_html() [1] netcam_setup_html: Netcam has flags: HTTP1.0: 1 HTTP1.1: 0 Keep-Alive OFF. [1] Camera connect string is ''GET HTTP/1.0 Host: iserj.ru User-Agent: Motion-netcam/3.2.12 Connection: close

'' [1] End of camera connect string. [1] netcam_setup_html: about to try to connect, time #0 [1] netcam_connect, disconnecting netcam since keep-alive not set. [1] netcam_connect with no keepalive, new socket created fd 3 [1] Received first header ('HTTP/1.0 400 Bad Request') [1] HTTP Result code 400 [1] netcam_setup_html: connected, going on to read image. [1] expanding buffer from 0 to 4096 bytes [1] netcam_read_html_jpeg disconnecting netcam since keep-alive not set. [1] libjpeg decompression failure on first frame - giving up! [1] File of type 2 saved to: /tmp/motion/01-20160324131720-snapshot.jpg [1] File of type 2 saved to: /tmp/motion/01-20160324131721-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131722-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131723-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131724-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131725-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131726-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131727-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131728-snapshot.jpg [0] DEBUG-2 threads_running 1 motion_threads_running 1 , finish 0 [1] File of type 2 saved to: /tmp/motion/01-20160324131729-snapshot.jpg

Help me to understand a problem. Excuse for bad English Best regards from Russia Thanks in advance

-- SerjJarmolenko - 24 Mar 2016
- potongan slip gaji



Follow up

Comments

Topic revision: r2 - 09 Aug 2017, AndikaJuniar
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.