Motion - Support Question 2005x 02x 02x 070318

Motion hangs up with multiple netcam

Question

I m using Motion 3.1.17 with 3 D-link DCS900 network cameras. It was working fine with 1 camera. Then I added two more and the problems started. Recording from the 1st camera is still OK but recording from the 2nd and 3rd hangs up from time to time. I heard of problems with these D-Link cameras that they sometimes hang up and they need to be restarted to get working again. But I dont think this is the case, because I can still connect to the camera via web browser. The suspicious thing is that when Motion stops recording from one of these two cameras, it doesnt respond to kill anymore. Only kill -9 works. After kill -9 and restart it works again for some time. Plz let me know if you need some additional information about this problem.

Thanks in advance

Martin Susil

Environment

Motion version: 3.1.17
ffmpeg version: 0.4.8
Libraries: curl, ffmpeg
Server OS: Slackware 9.1, kernel 2.4.22

-- MartinSusil - 02 Feb 2005

Answer

Version 3.1.18 was just released. The netcam code was completely rewritten.

There are some problems reported and they are being worked on. But we would like to know any experience you may have - good or bad.

-- KennethLavrsen - 02 Feb 2005
Topic revision: r2 - 02 Feb 2005, KennethLavrsen
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.