Motion - Support Question 2006x 06x 18x 011017

SOLVED - Could not start motion program .. frown, sad smile

Question

The problem is just that when I try to start motion, I get "error calling vid_start":

Could be the problem related to my config file? But what I changed was just few unimportant lines, like output folder for storing images

my error message:
---------------------------------------------------------
# motion -s
[0] Processing thread 0 - config file /etc/motion.conf
[0] Motion running in setup mode.
[0] Thread device: /dev/video0 input 8
[0] Thread is from /etc/motion.conf
[0] Waiting for threads to finish, pid: 25097
[1] Thread started
[1] Capture error calling vid_start
[1] Thread finishing...
---------------------------------------------------------

This is my caminfo output:
--------------------------------------------
Detected 1 Video4Linux devices.
Device node      : /dev/video0
Name of device   : "Logitech QuickCam Pro 3000"
Minimum size     : 160x120
Current size     : 0x0
Maximum size     : 640x480
Video inputs     : 1
 Input 0
  Name             : "Webcam"
  Type             : Camera
  Audio            : no
  Tuners           : 0
Audio inputs     : 1
 Input 0
  Name             : "Microphone"
  Mutable          : no
------------------------------------------------

Environment

Motion version: 3.2.4
ffmpeg version: 0.4.9_p20060302
Libraries: ffmpeg, mysql, postgresql
Server OS: Gentoo linux, kernel 2.6.16, using pwc module

-- LolekBoss - 18 Jun 2006

Answer

I will be all guessing unless you post your motion.conf file. You can attach it to this topic using the attach button. Easy.

Current shipping version of Motion is 3.2.6 so updating will also be a good idea.

-- KennethLavrsen - 18 Jun 2006


  • motion.conf: this is my configuration file .. I saw some setting that differs from default, but it was not me to change them, but gentoo team I think? And about upgrading, I will do it now.

OK, I upgraded manually to version 3.2.6 and now it works!!!

Thank you K.Lavrsen for your help and post reply!

I think I started to love this program =D Good ideas and great work!!

-- LolekBoss - 18 Jun 2006

Checked your config. Looks all OK.

Enjoy

-- KennethLavrsen - 18 Jun 2006
Topic attachments
I Attachment Action Size Date Who Comment
motion.confconf motion.conf manage 20 K 18 Jun 2006 - 14:35 UnknownUser this is my configuration file .. I saw some setting that differs from default, but it was not me to change them, but gentoo team I think? And about upgrading, I will do it now.
Topic revision: r4 - 18 Jun 2006, KennethLavrsen
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.