Motion - Support Question 2007x 04x 03x 000305

Logitech QuickCam Sphere MP gives me only pictures at 176x144

Question

Hello everyone, i got a new Logitech QuickCam Sphere MP and after hours of compiling and testing i finally got some pictures. But only at a size of 176x144 pixels. A little bit small for this cam.

After setting motion to debug i could see the following:

[1] Adjusting resolution from 640x480 to 176x144.

Why is motion adjusting the resolution to 176x144 ?

I compiled the latest motion snapshot (motion-20070402-051001). And the latest uvc snapshot.

./configure and make didn't report errors.

It would be great if somebody can help me on getting larger from this cam!

Thanks in advance

Starting motion detection : motion
[0] Processing thread 0 - config file /usr/local/etc/motion.conf
[0] Unknown config option "sql_log_image"
[0] Unknown config option "sql_log_snapshot"
[0] Unknown config option "sql_log_mpeg"
[0] Unknown config option "sql_log_timelapse"
[0] Unknown config option "sql_query"
[0] Motion running in setup mode.
[0] Thread 1 is from /usr/local/etc/motion.conf
[0] Thread 1 is device: /dev/video0 input 8
[0] Waiting for threads to finish, pid: 4208
[1] Thread started
[1] cap.driver: "uvcvideo"
[1] cap.card: "USB Video Class device"
[1] cap.bus_info: "0000:00:07.2"
[1] cap.capabilities=0x04000001
[1] - VIDEO_CAPTURE
[1] - STREAMING
[1] v4l2_select_input: name = "Camera", type 0x00000002, status 00000000
[1] - CAMERA
[1] Device doesn't support VIDIOC_G_STD
[1] Supported palettes:
[1] 0: MJPG (MJPEG)
[1] 1: YUYV (Uncompressed)
[0] motion-httpd/3.2.8 running, accepting connections
[0] motion-httpd: waiting for data on port TCP 8080
[1] Test palette YUYV (640x480)
[1] Adjusting resolution from 640x480 to 176x144.
[1] Using palette YUYV (176x144) bytesperlines 2816 sizeimage 50688 colorspace 00000008
[1] found control 0x00980900, "Brightness", range 0,255

Environment

Motion version: 3.2.7
ffmpeg version:  
Libraries: ffmpeg,
Server OS: Debian, Kernel 2.6.18-4-686

-- KarstenScholz - 03 Apr 2007

Follow Up

To Which USB port have you plugged your webcam , 1.0 / 1.1 or 2.0 ?

Motion adjust the size because the driver specify that requested size is not correct and give back to motion the supported size. Not sure what can be your problem but i guess that you don't have your camera connected to USB 2.0 port.

-- AngelCarpintero - 03 Apr 2007

Answer

This issue is not related to motion but driver and USB interface.

-- AngelCarpintero - 10 May 2008
Topic revision: r3 - 10 May 2008, AngelCarpintero
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.