Motion - Support Question 2008x 02x 04x 064521

Illegal Instruction

Question

I have installed motion with the built in package manager on archlinux. when I run motion I get the output below. Ne ideas on how I can get it working. I have searched the site and can only find two very old posts with the "Illegal Instruction" words in them, which are of no help. I am not a linux guru, I'm trying to learn. I have seen there is a debug option in the command line, but it doesent make any difference, and I dont see any diffirent output if I do use that option. Thanks

[root@mycomputer ~]# motion
[0] Processing thread 0 - config file /etc/motion/motion.conf
[0] Thread 1 is from /etc/motion/motion.conf
[1] Thread started
Illegal instruction

the config file is as follows

control_authentication=admin:1234
control_localhost=off
control_port=4000
daemon=off
netcam_url=192.168.7.3/snapshot.jpg

Environment

Motion version: 3.2.8
ffmpeg version:  
Libraries: ffmpeg, mysql, postgresql
Server OS: Archlinux

-- HooliganMD - 04 Feb 2008

Answer

You should update to 3.2.9 , it's latest starble release version of motion ... but i guess that your distro is using a version of ffmpeg that won't work with 3.2.9 because ffmpeg changed his API since svn -r 11071 and probably your ffmpeg version will be affected.

1-. Upgrade & test 3.2.9

2 -. If (1) didn't work , get motion-3.2.10 branch ( Follow instructions here to get 3.2.10 )

http://www.lavrsen.dk/twiki/bin/view/Motion/BugReport2008x01x27x155414

P.S : Next time fill "ffmpeg version" environment field.

-- AngelCarpintero - 04 Feb 2008
Topic revision: r4 - 06 Feb 2008, AngelCarpintero
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.