Motion - Support Question 2009x 01x 11x 213342

Motion and dv4l, problem similar to Support Question 2008x 08x 14x 014531?

Question

Motion does not start in conjunction with dv4l, showing errors, se below. Using other applications through /dev/video1, the images are: camorama: ok (but the program crash when I click the mouse out of program's window) vlc: ok camstream: too much blue-coloured

I tried to follow the instruction on motion-wiki, but no result, should I use motion 3.2.11? I would prefer ubuntu's version, bu I can try it.. Thanks for all info do you need motion.conf?

Motion output:
root@prok:/etc/motion# motion -n -d 9
[0] Processing thread 0 - config file motion.conf
[0] Motion 3.2.9 Started
[0] ffmpeg LIBAVCODEC_BUILD 3352064 LIBAVFORMAT_BUILD 3344896
[0] Thread 1 is from motion.conf
[1] Thread 1 started
[1] Not a V4L2 device?
[0] motion-httpd/3.2.9 running, accepting connections
[0] motion-httpd: waiting for data on port TCP 8080
[1] Using VIDEO_PALETTE_YUV420P palette
[1] Using V4L1
[1] Failed to open video loopback
[1] Thread finishing...

dv4l output in the meanwhile:
davide@prok:~$ sudo dv4l
use /dev/video1 in your webcam application

>here starts motion as above<

VIDIOCMCAPTURE invalid format 15
VIDIOCMCAPTURE invalid format 8
VIDIOCMCAPTURE invalid format 1

ffmpeg -version
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
  libavutil version: 1d.49.3.0
  libavcodec version: 1d.51.38.0
  libavformat version: 1d.51.10.0
  built on Jul 23 2008 22:38:24, gcc: 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
ffmpeg      SVN-rUNKNOWN
libavutil   3212032
libavcodec  3352064
libavformat 3344896

Environment

Motion version: 3.2.11
ffmpeg version: see above
Libraries: ffmpeg
Server OS: ubuntu 8.04, 2.6.24-19-generic

-- DavideSandini - 11 Jan 2009

Follow Up

I never used dv4l .. but looking at motion messages :
[1] Failed to open video loopback

Doesn't look good , be sure you load vloopback and d4vl properly.

You didn't give many details like your motion.conf and your video/virtual devices ( vloopback , dv4l ).

Last but not least OF COURSE you should use 3.2.11 ( i did some deb for hardy and also there's deb of 3.2.11 in ppa )

-- AngelCarpintero - 14 Jan 2009


Answer

No feedback. Probably fixed in current stable or svn version of motion / vloopback.

-- AngelCarpintero - 09 Aug 2009

SupportForm edit

TopicTitle Motion and dv4l, problem similar to Support Question 2008x 08x 14x 014531?
SupportStatus AnsweredQuestions
AssignedQuestionTo dv4l_support
SubmittedBy DavideSandini
Topic revision: r3 - 09 Aug 2009, AngelCarpintero
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.