Motion - Support Question 2015x 07x 20x 213901

stream_localhost = off not working - resolved

Question

Thank you for this free software and the support!

I have installed motion 3.2.12 on my Raspberry Pi 2 on Ubuntu Mate 1.8.2 and I am using a USB webcam with it. Everything seems to be working just fine. I get the image and the control page on their ports on localhost. Unfortunately, if I am using an external computer and try to open the streaming page (port 8081) using the Raspberrys IP in the network, I can't. I am, however, able to connect to port 8080 for the control page.

I tried to switch ports, but the same thing happens. Control page opens, streaming page does not. I played around with the settings, but I couldn't get it to work. I set stream_localhost = off and on and tried with variations of authentication. Any ideas, why this might happen and what I can do? Do you need more information about my system?

Edit: I just found out it was related to using Chrome... works like a charm in Safari...

Thank you!
[0] [NTC] [ALL] conf_load: Processing thread 0 - config file ~/.motion/motion.conf
[0] [ALR] [ALL] conf_cmdparse: Unknown config option "sdl_threadnr"
[0] [NTC] [ALL] motion_startup: Motion 3.2.12+git20140228 Started
[0] [NTC] [ALL] motion_startup: Logging to syslog
[0] [NTC] [ALL] motion_startup: Using log type (ALL) log level (NTC)
[0] [NTC] [ENC] ffmpeg_init: ffmpeg LIBAVCODEC_BUILD 3670016 LIBAVFORMAT_BUILD 3670272
[0] [NTC] [ALL] main: Thread 1 is from /home/ruben/.motion/motion.conf
[0] [NTC] [ALL] main: Thread 1 is device: /dev/video0 input -1
[0] [NTC] [ALL] main: Stream port 8080
[0] [NTC] [ALL] main: Waiting for threads to finish, pid: 4139
[1] [NTC] [ALL] motion_init: Thread 1 started , motion detection Enabled
[1] [NTC] [VID] vid_v4lx_start: Using videodevice /dev/video0 and input -1
[1] [NTC] [VID] v4l2_get_capability: 
------------------------
cap.driver: "uvcvideo"
cap.card: "USB2.0 Camera"
cap.bus_info: "usb-bcm2708_usb-1.5"
cap.capabilities=0x84000001
------------------------
[1] [NTC] [VID] v4l2_get_capability: - VIDEO_CAPTURE
[1] [NTC] [VID] v4l2_get_capability: - STREAMING
[0] [NTC] [STR] httpd_run: motion-httpd testing : IPV4 addr: 0.0.0.0 port: 8081
[0] [NTC] [STR] httpd_run: motion-httpd Bound : IPV4 addr: 0.0.0.0 port: 8081
[1] [NTC] [VID] v4l2_select_input: name = "Camera 1", type 0x00000002, status 00000000
[0] [NTC] [STR] httpd_run: motion-httpd/3.2.12+git20140228 running, accepting connections
[0] [NTC] [STR] httpd_run: motion-httpd: waiting for data on 0.0.0.0 port TCP 8081
[1] [NTC] [VID] v4l2_select_input: - CAMERA
[1] [WRN] [VID] v4l2_select_input: Device doesn't support VIDIOC_G_STD
[1] [NTC] [VID] v4l2_set_pix_format: Config palette index 17 (YU12) doesn't work.
[1] [NTC] [VID] v4l2_set_pix_format: Supported palettes:
[1] [NTC] [VID] v4l2_set_pix_format: (0) YUYV (YUV 4:2:2 (YUYV))
[1] [NTC] [VID] v4l2_set_pix_format: 0 - YUV 4:2:2 (YUYV) (compressed : 0) (0x56595559)
[1] [NTC] [VID] v4l2_set_pix_format Selected palette YUYV
[1] [NTC] [VID] v4l2_do_set_pix_format: Testing palette YUYV (640x480)
[1] [NTC] [VID] v4l2_do_set_pix_format: Using palette YUYV (640x480) bytesperlines 1280 sizeimage 614400 colorspace 00000008
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980900, "Brightness", range 0,100 
[1] [NTC] [VID] v4l2_scan_controls:    "Brightness", default -8193, current 30
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980901, "Contrast", range 0,100 
[1] [NTC] [VID] v4l2_scan_controls:    "Contrast", default 57343, current 57
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980902, "Saturation", range 0,4 
[1] [NTC] [VID] v4l2_scan_controls:    "Saturation", default 57343, current 2
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980910, "Gamma", range 1,8 
[1] [NTC] [VID] v4l2_scan_controls:    "Gamma", default 57343, current 3
[1] [NTC] [VID] vid_v4lx_start: Using V4L2
[1] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1] [NTC] [STR] http_bindsock: motion-stream testing : IPV4 addr: 0.0.0.0 port: 8080
[1] [NTC] [STR] http_bindsock: motion-stream Bound : IPV4 addr: 0.0.0.0 port: 8080
[1] [NTC] [ALL] motion_init: Started motion-stream server in port 8080 auth Disabled

Environment

Motion version: 3.2.12
ffmpeg version:  
Libraries: ffmpeg, mysql, postgresql
Server OS: Ubuntu Mate 1.8.2
-- RuGla - 20 Jul 2015

Answer

Topic revision: r1 - 20 Jul 2015, RuGla
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.