Motion - Support Question 2016x 04x 18x 124606

Foscam FI9803P V2 - Not able to get image

Question

I am trying to configure the Foscam FI9803P V2 camera and it is not working.
Hi,

My configuration file is:

netcam_url http://URL:8094/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=USR&pwd=PWD
netcam_keepalive on
netcam_tolerant_check on
text_left Test
target_dir /public/camaraip
snapshot_filename TEST_%Y%m%d_%H%M%S-snapshot
movie_filename TEST_%Y%m%d_%H%M%S
stream_port 9094

Using the http address I am able to get the snapshot for the camera.

Error log:
[4] [WRN] [ALL] [Apr 18 09:57:20] motion_loop: Retrying until successful connection with camera
[4] [ALR] [NET] [Apr 18 09:57:20] netcam_start: Network Camera thread starting... for url (http://url:8094/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=USR&pwd=PWD)
[4] [ERR] [NET] [Apr 18 09:57:20] netcam_read_first_header: Unrecognized content type
[4] [ERR] [NET] [Apr 18 09:57:20] netcam_http_request: Error reading first header - re-trying

What am I doing wrong?

Thanks in advance.

Bazcor

Environment

Motion version: 3.3.0
ffmpeg version: 2.6.8
Libraries: ffmpeg
Server OS: Centos 7
-- ManuelBesoain - 18 Apr 2016

Answer

Topic revision: r1 - 18 Apr 2016, ManuelBesoain
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.