Motion - Bug Report 2006x 02x 28x 192111

BUG: webcam_localhost behaviour

See support question SupportQuestion2006x02x24x095024

webcam_localhost setting in config file is ignored. Seen to be set to "off" in web interface even when specifically set to "on". Likewise control_localhost.

When webcam_localhost set to "on" can still access from remote computers. Not proved this with control interface.

Test case

set control_localhost to "on" in motion.conf and webcam_localhost to "on" in a thread and use web interface to check setting.

In web interface set to "on" - test access from another system.

Environment

Motion version: 3.2.4
ffmpeg version: 3:20060210-0.0
Shared libraries: ffmpeg, mysql
Server OS: debian unstable 2.6.14

-- DickMiddleton - 28 Feb 2006

Follow up

I don't understand your problem even i can't reproduce your problem. Unless you have a routeable lo interface what you said is not posible. Please try to check where is listening motion for control_port , i.ex if you have control_port 8080 :

netstat -ant

when i tried i got
127.0.0.1:8080

-- AngelCarpintero - 28 Feb 2006

Fix record

Topic revision: r2 - 28 Feb 2006, AngelCarpintero
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.