Motion - Bug Reports
You are here: Foswiki>Motion Web>BugReports (13 Nov 2016, MrDave)Edit Attach

Bug Reports

The page includes historic bug reports. It is not to be used for reporting any new bugs. New issues should be reported via the github home or reported, discussed and validated on the Motion user mailing list.

New Bugs

Not yet assigned to anyone.

Headline Submitted By Age Last Change
compiling error with latest ffmpeg on raspberrypi MarcoBernardi 291 11 Sep 2016 - 14:57
MarcoBernardi
mask image ignored or wrong setup? WolframFischer 314 21 Aug 2016 - 15:09
WolframFischer
Unable to run python script on_motion* etc... Main.turboy 371 23 Jun 2016 - 14:22
SimoneRiccardi
Unknown config option for Database options WikiGuest 407 18 May 2016 - 19:06
VictorO
Problem installing motion WikiGuest 498 17 Feb 2016 - 16:45
NicoBoileau
Libavformat53 error, not found WikiGuest 504 12 Feb 2016 - 00:35
RovilsonFMartins
Can't compile with V4L2 Allan Bogh 531 17 Jan 2016 - 10:48
AllanBogh
Skip corrupted jpeg frame MaurizioA 557 20 Dec 2015 - 16:18
MaurizioA
Recording timelapse video no longer working StefanBruda 1451 22 Nov 2015 - 18:49
MrDave
Still detecting motion even with "output_normal off" HenkVanHeuveln 603 22 Nov 2015 - 17:38
MrDave
Captured images are broken if their size is more than 1MB KonstantinSokolov 614 24 Oct 2015 - 20:38
KonstantinSokolov
logrotate crash HarlanDaneker 615 23 Oct 2015 - 20:01
HarlanDaneker
segfault in pthread_getspecific() on musl based system WikiGuest 638 30 Sep 2015 - 20:42
DaveFlogeras
Motion does not work with Chrome DavidRadin 1339 19 Aug 2015 - 17:16
MiKn
event_on_start not working StephenCook 700 30 Jul 2015 - 23:51
StephenCook
Threads dying randomly, just like BugReport2006x04x07x164654 HolgerJakobs 835 17 Mar 2015 - 18:23
HolgerJakobs
Memory usage of motion is extremly high if Netcam is in use - Raspberry Pi 512MB WikiGuest 932 10 Dec 2014 - 21:34
ChristopherStein
Fix for mem leak in read_rtsp_image() ChristopheGRENIER 933 10 Dec 2014 - 10:31
ChristopheGRENIER
height (1080) is not modulo 16 3.2.12: with 1920 x 1080 GeneC 938 05 Dec 2014 - 23:36
GeneC
Libjpeg Crash during conversion (YUV420 to JPEG) GiovanniLicata 1031 10 Nov 2014 - 15:41
GiovanniLicata
Multiple Vulnerabilities RvH 1576 10 Oct 2014 - 19:19
MrDave
* Error in `motion': free(): invalid size: 0x00007f960000dc60 * QwazwsxQwazwsx 1012 10 Oct 2014 - 19:00
MrDave
I have problem "netcam_output_message: Invalid SOS parameters for sequential JPEG" WikiGuest 1021 12 Sep 2014 - 12:09
AndrianAndrian
Killing motion makes webcam light stuck to on and device becomes unusable DanielSohn 1081 15 Jul 2014 - 03:38
DanielSohn
Higher 'gap' values in motion.conf break the framerate of the first event movie SimonLemarchand 1150 06 May 2014 - 17:20
SimonLemarchand
Several Instances of Memory leaks NicoleBruck 1156 01 May 2014 - 00:32
NicoleBruck
Recorded Video doesn't play JackYellow 1156 01 May 2014 - 00:20
JackYellow44
Compilation fails at video2.c on Raspberry Pi MartinGogo 1161 26 Apr 2014 - 09:25
MartinGogo
Motion with 2 cameras, only one works bomberb17 1177 09 Apr 2014 - 19:43
PanosXatzi
error: ‘VIDEO_PALETTE_YUV420P’ undeclared Main.Drootnar 1226 20 Feb 2014 - 09:29
DrootnarDrootnar
(PATCH) Handling of bad MJPEG/JPEG data JonGuess 1744 17 Feb 2014 - 06:36
KeithWillis
netcam with host and port does'nt works with proxy GVautier 1234 11 Feb 2014 - 15:02
GillesVautier
Ignore bad frames OERNiiB 1249 28 Jan 2014 - 08:50
OERNiiB
CPU load is not effected if motion detection is paused MaartenOll 1360 08 Oct 2013 - 13:45
MaartenOll
setting minimum_motion_frame to 1 stops image output until restart WilliamPhelps 1370 28 Sep 2013 - 18:24
WilliamPhelps
Mpeg4 video format doesn't work for HTML5 video PedroCorteReal 1418 11 Aug 2013 - 16:29
PedroCorteReal
Error with Threads LuanCasagrande 1427 02 Aug 2013 - 22:32
LuanCasagrande
"Motion thread 1 restart" when running as service JohnMiller 1439 21 Jul 2013 - 17:59
JohnMiller
No rollover if target file size is limited KlausMueller 1463 27 Jun 2013 - 20:20
KlausMueller
"compatible palette" error until fswebcam runs before Motion EricRead 1480 10 Jun 2013 - 18:45
EricRead
Autofocus cameras garbage MustaiMustai 1486 05 Jun 2013 - 03:33
MustaiMustai
mjpg-streaming broken with motion 3.2.12 WikiGuest 1515 07 May 2013 - 11:03
TomHinkle
Motion can't start X Display Applications ("on_event_start") in Daemon mode Main.Yusuf 1552 31 Mar 2013 - 06:51
YusufGungor
Unable to find a compatible palette format. PawelGrzes 1562 20 Mar 2013 - 14:38
PawelGrzes
vloopback_motion.c compile fails NormDePlume 1806 12 Mar 2013 - 16:12
RkaneKnight
8bit Greyscale support missing for uvcvideo device CavaC 1595 15 Feb 2013 - 19:57
CavaC
Errors at make (git version) IboS 1606 05 Feb 2013 - 02:47
IboS
Motion dies after going into daemon mode DazzConway 1624 29 Jan 2013 - 22:09
DazzConway
With two web cams conencted the pictures are mixed together in recordings IainMcFarlane 2197 25 Jan 2013 - 01:43
DazzConway
FLV generated movie files play too fast WikiGuest 1646 27 Dec 2012 - 05:16
OlegRakh
Dual webcam problem on Raspberry Pi WikiGuest 1660 12 Dec 2012 - 16:45
EnricoS
Segmentation fault with iViewHD net camera RzTen1 1681 21 Nov 2012 - 23:05
RzTen1
movie_filename unknown if no ffmpeg YoupMol 1698 05 Nov 2012 - 06:55
YoupMol
Filenames vs displaytime YoupMol 1700 03 Nov 2012 - 09:08
YoupMol
Make fails on file vloopback_motion.c SteveGee 1705 28 Oct 2012 - 21:04
SteveGee
recording fps rate : notice and fix (motion-3.2.12-trunk.r557) BernieK 1713 20 Oct 2012 - 17:17
BernieK
internet conflict with motion. WikiGuest 1717 16 Oct 2012 - 21:07
EdwinKribbs
Cannot compile any version. AndAnd 1755 08 Sep 2012 - 21:04
AndAnd
aera_detect not working at all BeBlochl 1812 19 Aug 2012 - 19:57
BeBlochl
Recent update of ports on FreeBSD = no more working motion WikiGuest 1799 27 Jul 2012 - 02:43
TisugolTisugol
Two USB cams on reporting to same Motion WikiGuest 2316 04 Mar 2012 - 19:29
GillesLatulipe
zero-copy mode of vloopback module on Linux kernel >2.6.32 RaulFajardo 2251 02 May 2011 - 09:09
RaulFajardo
Motion stops recording (but keeps running) WikiGuest 2345 28 Jan 2011 - 08:05
KetilMalde
Motion will crash when attempting to add a thread via the HTTP API. WikiGuest 2376 27 Dec 2010 - 18:26
KyleHotchkiss
motion ignores framerate and minimum_frame_time settings in Debian WikiGuest 2421 13 Nov 2010 - 05:10
JuanAnguloMoreno
Problem with "grey" video from motion AndreyChayka 2464 01 Oct 2010 - 11:08
AndreyChayka
/dev/cxm0 DarrenJohnston 2550 06 Jul 2010 - 23:55
DarrenJohnston
Auto brightness oscillates wildly RobertHancock 2988 25 Apr 2009 - 02:25
RobertHancock
on_camera_lost not triggered if video_pipe doesn't work for any reason. RomanGaufman 3025 03 Apr 2009 - 14:43
RomanGaufman
Motion failed to close motion-stream listen socket after a month of running RomanGaufman 3012 31 Mar 2009 - 15:16
RomanGaufman
Number of topics: 70

Assigned Bugs

Assigned to someone - feel free to help resolving it anyway.

Headline Submitted By Age Last Change Assigned To
Quantization table 0x00 was not defined AlexeyRod 2198 05 Sep 2012 - 23:21
LuisFernandoMita
AngelCarpintero
Video loopback broken with kernels 2.6.38 and above WikiGuest 2178 29 Oct 2011 - 02:36
AngelCarpintero
AngelCarpintero
netcam_next called with non data in buffer NicolaM 3038 04 Jan 2010 - 03:17
AngelCarpintero
AngelCarpintero
on_area_detected, events, gap WikiGuest 3015 09 Jul 2009 - 08:38
AngelCarpintero
JoergWeber
Number of topics: 4

Resolved Bugs

Bugs with a fix. The fix is not yet in a released version of Motion. See also MotionPatches which contains patches for both new features, enhancements and bug fixes.

Headline Submitted By Age Last Change Assigned To
Wireless IP Camera's Not Working MikeHoward 1061 26 Oct 2014 - 22:46
MikeHoward
 
trunkREV557: motion does not insert data to a postgresql db. KarolisE 1660 13 Dec 2012 - 12:41
KarolisE
 
Gentoo emerge motion fails, video2.c undeclared JoeKane 1821 07 Jul 2012 - 18:31
AngelCarpintero
 
motion.c:585:26: error: ‘VIDEO_PALETTE_YUV420P’ undeclared (first use in this function) IgorKuznetsov 1843 14 Jun 2012 - 15:20
AngelCarpintero
AngelCarpintero
Connexion to non-streaming netcam lost after some time F00tyNyupi 2532 28 Jul 2010 - 19:27
F00tyNyupi
 
Unclear explanantion in configuration file for stream_quality RichardB 2707 21 Mar 2010 - 18:35
AngelCarpintero
AngelCarpintero
V4L2 fourcc GRBG not supported IsaacRichter 2800 24 Nov 2009 - 12:20
AngelCarpintero
AngelCarpintero
New spec and init script for Fedora/RedHat systems StevenM 3015 06 Jul 2009 - 13:29
StevenM
 
Number of topics: 8

Monitored Bug Reports

Headline Submitted By Age Last Change
IP cam connection lost and never reconnect LaurentBalthasar 3846 30 Jun 2016 - 00:12
PhilipWalden
Colors not coming out correctly when using webcam with JPEG palette WikiGuest 2140 05 Sep 2012 - 03:54
GatorY
svn/git version don't compile with mysql support under ubuntu 12.04 DannyDeKeuleneire 1814 18 Jul 2012 - 09:00
DannyDeKeuleneire
support for new major ffmpeg release EmmettBrown 1843 18 Jul 2012 - 06:30
AngelCarpintero
Segfault on 16:9 resolution MichaelKirkland 1933 02 Jun 2012 - 04:40
AngelCarpintero
cppcheck FolkertvanHeusden 1855 02 Jun 2012 - 01:56
AngelCarpintero
motion will not compile with ffmpeg EdwinKribbs 2405 29 Oct 2011 - 01:56
AngelCarpintero
motion.c:585:26: error: 'VIDEO_PALETTE_YUV420P' undeclared (first use in this function) WikiGuest 2104 22 Oct 2011 - 17:06
AngelCarpintero
Crash when write mpeg4, swf and etc WikiGuest 2095 22 Oct 2011 - 17:04
AngelCarpintero
Motion will not build with newer kernel headers IgorNovgorodov 2277 10 May 2011 - 06:21
AngelCarpintero
image scrambled, videosyncs inside active picture? RubenD 2315 27 Feb 2011 - 18:56
RubenD
Segmentation fault WikiGuest 2645 10 Feb 2011 - 02:05
AngelCarpintero
Events leave zombies on OpenBSD MotionMark 2620 02 May 2010 - 15:45
AngelCarpintero
Locked pixels FlorinAnton 2909 11 Feb 2010 - 19:06
FlorinAnton
Mac OS X ffmpeg patch/configure error & Motion pthread support error NicholasSund 3113 05 Feb 2010 - 21:14
AngelCarpintero
./configure without ffmpeg WikiGuest 2732 07 Jan 2010 - 10:56
AngelCarpintero
False recordings of gabage TheOtherBug 2898 24 Jul 2009 - 10:50
TheOtherBug
segfault in libc-2.6.1.so WikiGuest 2907 18 Jul 2009 - 00:41
AngelCarpintero
Segmentation fault JeanBono 2933 16 Jul 2009 - 18:57
AngelCarpintero
Motion control 'quit" action does not work. BruceDurham 3159 06 Nov 2008 - 03:05
AngelCarpintero
3.2.9 and Logitech QuickCam Pro 4000: captures 320x240 despite a setting of 640x480 although set to TWikiGuest 3211 15 Sep 2008 - 18:56
DagErlandsson
Logitech Quickcam Messenger : image much too bright TWikiGuest 3273 15 Jul 2008 - 17:31
AngelCarpintero
Need to set norm to NTSC in xawtv for threads beyond 0 WillBuddenberg 3502 15 Jun 2008 - 23:54
AngelCarpintero
Crash on reconect webcam TrebolA 3319 02 Jun 2008 - 16:04
AngelCarpintero
Motion hangs if webcam is removed PekkaVuorela 3330 22 May 2008 - 20:48
PekkaVuorela
post_capture seems to stop on max_mpeg_time :( TWikiGuest 3365 22 May 2008 - 01:13
AngelCarpintero
Stop answering. DanielHolm 3419 20 Feb 2008 - 19:27
DanielHolm
Motion for MACOSX 10.4 (ppc) TWikiGuest 3438 31 Jan 2008 - 09:45
AngelCarpintero
motion 3.2.8 on fox board Luca 3601 08 Jan 2008 - 16:24
AngelCarpintero
multiple definition of `file_protocol' GerbenRoest 3501 02 Dec 2007 - 20:54
AngelCarpintero
compile error with ffmpeg + solution NickKnatterton 3592 31 Aug 2007 - 21:23
AngelCarpintero
motion dies in webcam.c:webcam_add_write:233 Uwe Klein 3805 31 Jan 2007 - 16:19
UweKlein
motion in free(): error: modified (chunk-) pointer. Occurs when I use features ffmpeg on FreeBSD. RafisKhayrullin 3846 08 Jan 2007 - 20:39
AngelCarpintero
Problem with webcam, based on the sn9c102 chip GennadySolovyenko 3893 05 Nov 2006 - 11:52
AngelCarpintero
Links between Camorama and Motion ? AndrewKraknovic 3958 06 Sep 2006 - 00:28
AngelCarpintero
Image is always black TWikiGuest 4013 17 Jul 2006 - 15:19
KonradRiedel
Webcam interface crashes after 24-48 hours. TWikiGuest 4237 22 May 2006 - 18:31
PeterS
Session timeout on netcam MarcBalcells 4063 16 May 2006 - 21:54
AngelCarpintero
disk full TWikiGuest 4144 28 Feb 2006 - 23:29
AngelCarpintero
webcam_localhost behaviour DickMiddleton 4139 28 Feb 2006 - 23:08
AngelCarpintero
segfault after start with WCS2003(same as wvc54g from Linksys) netcam and motion-3.2.2 Mirko Taschenberger 4336 16 Aug 2005 - 22:04
KennethLavrsen
on round robin * glibc detected * free(): invalid pointer: 0xb4658008 * RobertoSpadim 4435 19 Jul 2005 - 03:13
KennethLavrsen
Number of topics: 42

Old Bugs

See ReleaseBugFixes for bugs that have been fixed and the fix is in a released version of Motion.

See RejectedBugReports for bugs that either cannot be reproduced, waiting for additional info or we believe it has been fixed in a new version.

See DuplicatedBugReports for bugs that are duplicates of others
Topic attachments
I Attachment Action Size Date Who Comment
crash_fixes.patchpatch crash_fixes.patch manage 31 K 23 Aug 2015 - 00:11 DavidFries git change log set of crash fixes
Topic revision: r27 - 13 Nov 2016, MrDave
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.