Motion - Release Bug Fixes

Released Bug Fixes

Bugs that have been fixed and the fix is in a released version of Motion.

Headline Submitted By Age Last Change
netcam green screen DennisOpanasenko 4078 12 Feb 2013 - 17:30
ArnoTixe
Segfault when using with tw68 RomanGaufman 3466 03 Jun 2012 - 01:54
AngelCarpintero
Genius Cam doesn't work with karmic and motion 3.2.11.1. WikiGuest 3553 03 Jun 2012 - 01:53
AngelCarpintero
Motion beyond 20100121 no longer builds without ffmpeg RichardB 3490 03 Jun 2012 - 01:53
AngelCarpintero
camera input parameter is valid from 0 to 15 except 8 LaszloVarga 3132 03 Jun 2012 - 01:52
AngelCarpintero
Cannot compile with latest ffmpeg (SVN-r25563) BertrandAchard 3221 03 Jun 2012 - 01:52
AngelCarpintero
linux/videodev.h: No such file or directory WikiGuest 2751 03 Jun 2012 - 01:52
AngelCarpintero
Seg Fault in fresh REV504 compile JimHoward 3423 03 Jun 2012 - 01:51
AngelCarpintero
Name space clash with libjpeg8 KennethLavrsen 3497 03 Jun 2012 - 01:50
AngelCarpintero
Motion won't compile with ljbjpeg >=8 McGibbon 3447 03 Jun 2012 - 01:49
AngelCarpintero
No mysql_close RichardA 3193 03 Jun 2012 - 01:48
AngelCarpintero
ffmpeg writes FLV files even when FFV1 is selected. TobyCorkindale 3416 03 Jun 2012 - 01:44
AngelCarpintero
'VIDEO_PALETTE_YUV420P’ undeclared is coming back WikiGuest 2745 02 Jun 2012 - 04:49
AngelCarpintero
SEGV on reload or quit for vloopback (maybe other v4l1 devices too) WikiGuest 3716 17 Apr 2010 - 18:11
AngelCarpintero
Possible buffer overflow StevenM 3821 10 Aug 2009 - 00:44
AngelCarpintero
UVCVideo not working in Ubuntu 8.10 kernel 2.6.27 TWikiGuest 3855 10 Aug 2009 - 00:44
AngelCarpintero
error in make.../usr/include/ffmpeg/libavformat/avformat.h:714: error: expected declaration specifiers or '...' before 'AVPacket' MeuNome 3763 10 Aug 2009 - 00:43
AngelCarpintero
__USE_GNU redefined PeterHolik 3715 10 Aug 2009 - 00:43
AngelCarpintero
configure script can't find ffmpeg include files AxelRossberg 3858 10 Aug 2009 - 00:43
AngelCarpintero
Ubuntu (bug-fix) packages available from Ubuntu PPA repository IntuitiveNipple 4047 10 Aug 2009 - 00:42
AngelCarpintero
Segfault due to incorrect checking for strerror_r in motion_log (motion.c) MoronicRegistration 3775 10 Aug 2009 - 00:26
AngelCarpintero
motion spams /var/log/messages WikiGuest 3737 10 Aug 2009 - 00:21
AngelCarpintero
motion crashes with 'codec not found' error on debian ('testing') FolkertvanHeusden 4347 12 Apr 2009 - 03:53
DmitriRodik
IS BugReport2006x03x10x000151 really fixed? TeamLoser 4730 02 Mar 2009 - 16:25
AngelCarpintero
Motion dies when running megapixel image GunnarSkjold 4083 22 Sep 2008 - 05:46
AngelCarpintero
Netcam gives "Error reading image header" occasionally SimonW 4192 22 Sep 2008 - 05:46
AngelCarpintero
Deb packages for ubuntu try to run daemon when installing it BradTempleton 4069 20 Sep 2008 - 16:55
AngelCarpintero
configure --with-pgsql=DIR checking postgresql does not return results JunqianXu 4194 20 Sep 2008 - 16:55
AngelCarpintero
Motion Web Bug TWikiGuest 4120 20 Sep 2008 - 16:54
AngelCarpintero
d-link dcs-900 connection lost after a short time TWikiGuest 4222 18 May 2008 - 23:35
AngelCarpintero
mjpegtools breaks compilation in AMD64 AngelCarpintero 4319 18 May 2008 - 23:34
AngelCarpintero
motion won't reconnect to mysql server if it's disconnected A3ricJohanson 4436 18 May 2008 - 23:34
AngelCarpintero
RoundRobin v4l2 buffers in driver when switching input DagErlandsson 4426 18 May 2008 - 23:33
AngelCarpintero
Can't get better pixel resolution IraMoss 4422 18 May 2008 - 23:33
AngelCarpintero
Problem of a motion on architecture x86_64. RafisKhayrullin 4314 18 May 2008 - 23:32
AngelCarpintero
Choose preferable palette bug? OnakraName 4229 18 May 2008 - 23:30
AngelCarpintero
Uninitialized Struct in v4l_set_input JasonSharpee 4285 18 May 2008 - 23:30
AngelCarpintero
httpd control is totally broken now KennethLavrsen 4283 18 May 2008 - 23:29
AngelCarpintero
http control uses invalid html AxelAmthor 4286 18 May 2008 - 23:29
AngelCarpintero
Motion doesn't build with latest ffmpeg Georgi D. Sotirov 4335 18 May 2008 - 23:29
AngelCarpintero
motion can't open motion.conf JohnBray 4194 18 May 2008 - 23:27
AngelCarpintero
3.2.8_beta1 - picture's red and blue colours are swaped. using v4l2 sn9c102 driver JaredD 4459 21 Feb 2008 - 06:38
KennethLavrsen
Segmentation fault at video_common.c:830 DamianWrobel 4525 21 Feb 2008 - 06:37
KennethLavrsen
Bug in ffmpeg_avcodec_log KennethLavrsen 4531 21 Feb 2008 - 06:36
KennethLavrsen
Can't Compile 64 bit KevinMifflin 4603 21 Feb 2008 - 06:35
KennethLavrsen
Captured images become corrupted on FreeBSD (6.2-RC1) TWikiGuest 4643 21 Feb 2008 - 06:33
KennethLavrsen
MySQL does not reconnect if connection is dropped GunnarSkjold 4697 21 Feb 2008 - 06:33
KennethLavrsen
Tracking only X (Pan) with value from Y(Tilt) DirkWesenberg 4540 06 Feb 2008 - 04:49
AngelCarpintero
Motion hangs when quit/restarted through the web control interface. DamonKohler 4293 11 Dec 2007 - 09:19
AngelCarpintero
motion-3.2.8_beta1 compile problems with -DWITHOUT_V4L EvilPete 4496 29 Apr 2007 - 19:54
AngelCarpintero
mySQL not working KevinMifflin 4608 29 Apr 2007 - 18:42
AngelCarpintero
warning, clipping 1 dct coefficients to -127..127 KennethLavrsen 5125 16 Nov 2006 - 17:08
SimonW
superfluous free in ffmpeg.c EvilPete 4967 20 Oct 2006 - 21:46
KennethLavrsen
sql_mask not initialisated correctly AngelCarpintero 4970 20 Oct 2006 - 21:42
KennethLavrsen
Segmentation Fault on Size Changes, when Mask Image doesn't fit AxelAmthor 5063 20 Oct 2006 - 21:42
KennethLavrsen
CPU usage at 99.99% if all network cameras are PAUSED GregSwift 4941 20 Oct 2006 - 21:26
KennethLavrsen
Pan & Tilt broken TWikiGuest 4988 20 Oct 2006 - 21:23
KennethLavrsen
error compiling version 3.2.5.1 (time_last_frame and time_current_frame undeclared) AndreaDelPriore 4912 20 Oct 2006 - 21:20
KennethLavrsen
Netcam reconnects floods syslog KennethLavrsen 4878 20 Oct 2006 - 21:18
KennethLavrsen
Motion won't exit until it has reconnected to all cameras after a successful start JeffGroves 4949 20 Oct 2006 - 21:18
KennethLavrsen
auto brightness "blinks" AndrzejJanuszkiewicz 4941 20 Oct 2006 - 21:15
KennethLavrsen
configure fails testing -pthread on FreeBSD TWikiGuest 4791 20 Oct 2006 - 20:49
KennethLavrsen
configure defines a redundant freebsd for motion on FreeBSD TWikiGuest 4791 20 Oct 2006 - 20:48
KennethLavrsen
Detection on all threads isnt pause when it is paused on thread 0 GunnarSkjold 4789 20 Oct 2006 - 20:47
KennethLavrsen
Random child threads appear to get killed PeterS 4882 20 Oct 2006 - 20:42
KennethLavrsen
Video signal lost - Adding grey image TheOtherBug 4911 20 Oct 2006 - 20:41
KennethLavrsen
Network Camera snapshots every 60 seconds frequently MISSING GregSwift 4941 12 Mar 2006 - 00:23
KennethLavrsen
Segfault with Motion 3.2.4 and Axis 206M PeterS 4991 02 Jan 2006 - 17:34
PeterS
configure issues NevDull 5086 18 Dec 2005 - 10:30
KennethLavrsen
switchfilter option broken - no motion detected at all KennethLavrsen 5066 18 Dec 2005 - 10:30
KennethLavrsen
Motion quits if any netcams falter at startup. BruceDurham 5074 18 Dec 2005 - 10:30
KennethLavrsen
Zombies are back after signal was replaced by sigaction KennethLavrsen 5028 18 Dec 2005 - 10:29
KennethLavrsen
Motion 3.2.3 crashes with Seg Fault at first detection JMB 5009 18 Dec 2005 - 10:26
KennethLavrsen
Zombie processes from onsave and onmpeg scripts BruceDurham 5412 06 Oct 2005 - 15:21
FredericLOIRETTE
motion events written in reverse order (with netcams) PhilipWalden 5149 29 Aug 2005 - 19:30
KennethLavrsen
Autobrightness is unstable TWikiGuest 5117 17 Aug 2005 - 19:10
KennethLavrsen
Text Display detected as motion Dennis DeDonatis 5117 17 Aug 2005 - 14:37
TWikiGuest
NO proxy support for netcams anymore TWikiGuest 5256 13 Aug 2005 - 19:53
KennethLavrsen
Motion crashes with multiple netcams in v3.1.18 and higher BruceDurham 5280 13 Aug 2005 - 19:53
KennethLavrsen
Cannot compile with latest ffmpeg cvs again KennethLavrsen 5127 13 Aug 2005 - 19:52
KennethLavrsen
Duplicate Images Output AndrewHamilton 5127 13 Aug 2005 - 17:34
KennethLavrsen
accept(): Socket operation on non-socket Dennis DeDonatis 5131 02 Aug 2005 - 23:05
KennethLavrsen
Return of BugReport2005x02x11x170019: Error when building RPMs, attempt to mv nonexistent file PaulBeltrani 5149 02 Aug 2005 - 23:04
KennethLavrsen
Pthread deadlock in motion 3.2.1 ChristopheGRENIER 5198 02 Aug 2005 - 23:04
KennethLavrsen
Motion will not run with ffmpeg 0.4.9pre1 CVS build from at least 20050517 and on. KennethLavrsen 5171 11 Jul 2005 - 18:05
KennethLavrsen
Http Header issue in http control RobertH 5222 29 May 2005 - 06:25
KennethLavrsen
Motion 3.2.1 will not compile with --without-v4l KennethLavrsen 5259 27 May 2005 - 04:06
KennethLavrsen
File Descriptor leak ChristopheGRENIER 5265 27 May 2005 - 04:05
KennethLavrsen
gap setting does not include 'post_capture' frames TerryRiggins 5315 27 May 2005 - 04:05
KennethLavrsen
Segment violation Heap corruption in rgb24toyuv420p (video.c) DanielLadd 5256 27 May 2005 - 04:04
KennethLavrsen
Quickcam Express + Motion -> Bad picture Kevin Drapel 5285 27 May 2005 - 04:04
KennethLavrsen
Multible Netcams doesnt work longer EmptySoft 5301 27 May 2005 - 04:03
KennethLavrsen
When setting low_cpu to non zero CPU load increases WillCooke 5230 27 May 2005 - 04:02
KennethLavrsen
auto_brightness function cycles between black and white, causing false triggers GearboxGraeme 5287 27 May 2005 - 04:02
KennethLavrsen
webcam.c RobertoSpadim 5222 27 May 2005 - 04:02
KennethLavrsen
webcam.c still with problem RobertoSpadim 5218 27 May 2005 - 04:01
KennethLavrsen
ffmpeg reports only YUV420 is supported KennethLavrsen 5202 27 May 2005 - 04:00
KennethLavrsen
Unknown content type with lumenera cameras aaron 5218 27 May 2005 - 04:00
KennethLavrsen
Sometimes motion try to free an invalid memory area ChristopheGRENIER 5204 27 May 2005 - 03:59
KennethLavrsen
Motion 3.2.1 memory leaks heavily when restarted through http control KennethLavrsen 5241 27 May 2005 - 03:58
KennethLavrsen
Network error for a single netcam thread causes motion to quit everything. BruceDurham 5311 12 Apr 2005 - 05:26
BruceDurham
Timelapse feature failes with ffmpeg_timelapse = 1 KennethLavrsen 5313 10 Mar 2005 - 00:44
KennethLavrsen
The streaming netcam feature doesn't appear to work with the Panasonic KX-HCM280. BruceDurham 5329 10 Mar 2005 - 00:43
KennethLavrsen
motionhttpcontrol logitech sphere track set problem RedDevil 5284 10 Mar 2005 - 00:41
KennethLavrsen
Netcam code in 3.1.18 is not stable KennethLavrsen 5313 10 Mar 2005 - 00:39
KennethLavrsen
Segmentation fault Peter Holschbach 5334 07 Mar 2005 - 20:33
KennethLavrsen
still get configure: error: cannot compute sizeof (short int),77 SebaT 5307 25 Feb 2005 - 19:43
AngelCarpintero
Illegal instruction Zoltan Zagarics 5314 25 Feb 2005 - 19:42
AngelCarpintero
Add support for destination directory during RPM builds Paul Beltrani 5302 14 Feb 2005 - 05:22
AngelCarpintero
Error when building RPMs, attempt to mv nonexistant file Paul Beltrani 5302 14 Feb 2005 - 04:55
AngelCarpintero
received signal SIGFPE, Arithmetic exception AngelCarpintero 5361 30 Jan 2005 - 13:31
KennethLavrsen
Doesn't read ~/motion.conf but ~/.motion/motion.conf Samuli Kärkkäinen 5339 30 Jan 2005 - 13:31
KennethLavrsen
What does "don't mix with noise_tune" mean SamuliKaerkkaeinen 5339 30 Jan 2005 - 13:30
KennethLavrsen
Crash when using a netcam configuration TWikiGuest 5335 30 Jan 2005 - 13:30
KennethLavrsen
Rotate doesn't work Mark Tranchant 5331 30 Jan 2005 - 13:29
KennethLavrsen
Feature: wrap up mpeg4 file at ^C SamuliKaerkkaeinen 5338 30 Jan 2005 - 13:29
KennethLavrsen
rotate 180 option create segfault JeremyBrun 5373 30 Jan 2005 - 13:29
KennethLavrsen
Receiving application bug warnings from SYSLOG in Redhat AS 3 PeterS 5410 30 Jan 2005 - 13:28
KennethLavrsen
Timelapse rollover at midnight does not always happen KennethLavrsen 5321 30 Jan 2005 - 13:28
KennethLavrsen
memory leak Chris Schleiermacher 5386 20 Dec 2004 - 23:16
KennethLavrsen
Trouble capturing ffmpeg movie 640x480 at 25fps. KalleAndersson 5412 20 Dec 2004 - 23:15
KennethLavrsen
pwc motion tracking problem Jan 5392 20 Dec 2004 - 22:44
KennethLavrsen
Leading spaces of text_left and text_right lost when saving with xmlrpc MikeLees 5412 01 Nov 2004 - 01:20
KennethLavrsen
Number of topics: 123
Topic revision: r1 - 28 Jan 2010, KennethLavrsen
Copyright © 1999-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.