Motion - Bug Report 2011x 06x 23x 191427

BUG: Quantization table 0x00 was not defined

With laptop build-in camera seems to work fine, but with some cheap USB cam (dont know brand, gcpca_pac7302) - this error

[0] [NTC] [ALL] motion_startup: Motion trunkREV528 Started
[0] [NTC] [ALL] motion_startup: Logging to syslog
[0] [NTC] [ALL] motion_startup: Using log type (ALL) log level (NTC)
[0] [NTC] [ALL] main: Thread 1 is from /usr/local/etc/motion.conf
[0] [NTC] [ALL] main: Thread 1 is device: /dev/video1 input -1
[0] [NTC] [ALL] main: Stream port 8081
[0] [NTC] [ALL] main: Waiting for threads to finish, pid: 2354
[1] [NTC] [ALL] motion_init: Thread 1 started
[1] [NTC] [VID] vid_v4lx_start: Using videodevice /dev/video1 and input -1
[1] [NTC] [VID] v4l2_get_capability: 
------------------------
cap.driver: "pac7302"
cap.card: "USB Camera (093a:2620)"
cap.bus_info: "usb-0000:00:1d.1-2"
cap.capabilities=0x05000001
------------------------
[1] [NTC] [VID] v4l2_get_capability: - VIDEO_CAPTURE
[1] [NTC] [VID] v4l2_get_capability: - READWRITE
[1] [NTC] [VID] v4l2_get_capability: - STREAMING
[1] [NTC] [VID] v4l2_select_input: name = "pac7302", type 0x00000002, status 00000000
[1] [NTC] [VID] v4l2_select_input: - CAMERA
[1] [WRN] [VID] v4l2_select_input: Device doesn't support VIDIOC_G_STD
[1] [NTC] [VID] v4l2_do_set_pix_format: Testing palette PJPG (320x240)
[1] [WRN] [VID] v4l2_do_set_pix_format: Adjusting resolution from 320x240 to 640x480.
[1] [NTC] [VID] v4l2_do_set_pix_format: Using palette PJPG (640x480) bytesperlines 640 sizeimage 115790 colorspace 00000007
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980900, "Brightness", range 0,32 
[1] [NTC] [VID] v4l2_scan_controls:    "Brightness", default 16, current 16
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980901, "Contrast", range 0,255 
[1] [NTC] [VID] v4l2_scan_controls:    "Contrast", default 127, current 127
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980902, "Saturation", range 0,255 
[1] [NTC] [VID] v4l2_scan_controls:    "Saturation", default 127, current 127
[1] [NTC] [VID] v4l2_scan_controls: found control 0x0098090e, "Red", range 0,3 
[1] [NTC] [VID] v4l2_scan_controls:    "Red", default 1, current 1
[1] [NTC] [VID] v4l2_scan_controls: found control 0x0098090f, "Blue", range 0,3 
[1] [NTC] [VID] v4l2_scan_controls:    "Blue", default 1, current 1
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980911, "Exposure", range 0,1023 
[1] [NTC] [VID] v4l2_scan_controls:    "Exposure", default 66, current 55
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980912, "Auto Gain", range 0,1 
[1] [NTC] [VID] v4l2_scan_controls:    "Auto Gain", default 1, current 1
[1] [NTC] [VID] v4l2_scan_controls: found control 0x00980913, "Gain", range 0,255 
[1] [NTC] [VID] v4l2_scan_controls:    "Gain", default 127, current 127
[0] [NTC] [STR] httpd_run: motion-httpd testing : IPV4 addr: 127.0.0.1 port: 8080
[0] [NTC] [STR] httpd_run: motion-httpd Bound : IPV4 addr: 127.0.0.1 port: 8080
[0] [NTC] [STR] httpd_run: motion-httpd/trunkREV528 running, accepting connections
[0] [NTC] [STR] httpd_run: motion-httpd: waiting for data on 127.0.0.1 port TCP 8080
[1] [NTC] [VID] vid_v4lx_start: Using V4L2
[1] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
Quantization table 0x00 was not defined
Quantization table 0x00 was not defined
Quantization table 0x00 was not defined
... and so on...

Environment

Motion version: trunkREV528
ffmpeg version:  
Shared libraries:  
Server OS: Ubuntu, 2.6.38-8-generic
-- AlexeyRod - 23 Jun 2011

Follow up

Please , can you try to reproduce with current version of motion SVN or GIT and post the version of driver you are using .

Thanks !

Cheers,

-- AngelCarpintero - 29 Oct 2011

The bug is still not resolved

Hello, I am a new member and this is my first post.
I also tested with this driver Motion and does not work:
motion version: trunkREV554
gspca driver: version shipped with 3.2.0-29-generic-pae 32bits linux kernel
(latest version of Ubuntu on servers until September 5, 2012)
Motion version: trunkREV554
ffmpeg version: (disabled)
Shared libraries:  
Server OS: Ubuntu, 3.2.0-29-generic-pae
-- LuisFernandoMita - 05 Sep 2012

Fix record

Topic revision: r3 - 05 Sep 2012, LuisFernandoMita
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.